#!/bin/sh
CWD=`pwd`
PKG=/tmp/package-libusb

VERSION=0.1.8
ARCH=i486
BUILD=1

if [ "$ARCH" = "i386" ]; then
  SLKCFLAGS="-O2 -march=i386 -mcpu=i686"
elif [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mcpu=i686"
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -march=x86_64"
fi
rm -rf $PKG
mkdir -p $PKG
cd /tmp
rm -rf libusb-$VERSION
tar xzvf $CWD/libusb-$VERSION.tar.gz
cd libusb-$VERSION
zcat $CWD/libusb_0.1.8-5.diff.gz | patch -p1
chown -R root.root .
find . -perm 777 -exec chmod 755 {} \;
find . -perm 664 -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr
make
make install DESTDIR=$PKG
chown -R root.bin $PKG/usr/bin
( cd $PKG
  find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
  find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
)
mkdir -p $PKG/usr/doc/libusb-$VERSION
cp -a \
  AUTHORS COPYING ChangeLog NEWS README doc/html \
  $PKG/usr/doc/libusb-$VERSION
gzip -9 $PKG/usr/man/man?/*.?
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
makepkg -l y -c n ../libusb-$VERSION-$ARCH-$BUILD.tgz