#!/bin/sh
# Set initial variables:
CWD=`pwd`
if [ "$TMP" = "" ]; then
  TMP=/tmp
fi
PKG=$TMP/package-clisp

VERSION=2.35
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}

if [ "$ARCH" = "i386" ]; then
  SLKCFLAGS="-O2 -march=i386 -mcpu=i686"
elif [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mcpu=i686"
elif [ "$ARCH" = "s390" ]; then
  SLKCFLAGS="-O2"
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2"
fi

if [ ! -d $TMP ]; then
  mkdir -p $TMP # location to build the source
fi
rm -rf $PKG
mkdir -p $PKG # place for the package to be built

#=================================================================
# First we need this.  It used to ship with CLISP, but no longer does.
cd $TMP
rm -rf libsigsegv-2.1
tar xjvf $CWD/libsigsegv-2.1.tar.bz2
cd libsigsegv-2.1
chown -R root.root .
#./configure --prefix=/usr --enable-shared=yes --enable-static=yes
CFLAGS="$SLKCFLAGS" \
./configure --prefix=/usr --enable-static=yes
make -j3
# Now I must install this.  Sorry, it's gotta happen.
make install
# Now add to the package:
mkdir -p $PKG/usr
make install prefix=$PKG/usr
strip --strip-unneeded $PKG/usr/lib/*.so
strip -g $PKG/usr/lib/*.a
mkdir -p $PKG/usr/doc/clisp-$VERSION/libsigsegv-2.1
cp -a \
  AUTHORS COPYING ChangeLog NEWS PORTING README \
  $PKG/usr/doc/clisp-$VERSION/libsigsegv-2.1
#=================================================================
 
cd $TMP
rm -rf clisp-$VERSION
tar xjvf $CWD/clisp-$VERSION.tar.bz2
cd clisp-$VERSION
chown -R root.root .
./configure --prefix=/usr with-gcc-wall
cd with-gcc-wall
./makemake --with-dynamic-ffi --prefix=/usr > Makefile
make config.lisp
make
#make check
make install DESTDIR=$PKG
# Strip stuff:
( cd $PKG
  find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
  find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
)
chown -R root.bin $PKG/usr/bin
mv $PKG/usr/share/doc/clisp/* $PKG/usr/doc/clisp-$VERSION
rm -f $PKG/usr/doc/clisp-$VERSION/clisp.{dvi,html,ps}
rm -r $PKG/usr/share/{doc,dvi,html}
mv $PKG/usr/share/man $PKG/usr/man
gzip -9 $PKG/usr/man/man?/*.?
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

# Build the package:
cd $PKG
makepkg -l y -c n $TMP/clisp-$VERSION-$ARCH-$BUILD.tgz