CWD=`pwd`
PKG=/tmp/package-python
rm -rf $PKG
mkdir -p $PKG

VERSION=2.3.1
ARCH=i486
BUILD=1

cd /tmp
rm -rf Python-$VERSION
tar xjvf $CWD/Python-$VERSION.tar.bz2
cd Python-$VERSION
chown -R root.root .
find . -type d -exec chmod 755 {} \;
find . -type f -perm 775 -exec chmod 755 {} \;
find . -type f -perm 664 -exec chmod 644 {} \;
find . -type d -name CVS -exec rm -r {} \;
./configure --prefix=/usr \
            --with-ncurses \
            --with-threads
# Normally I don't trust -O3, but it is the Python default so
# I'll assume that in this case it has been well tested.
make OPT="-O3 -march=i486 -mcpu=i686"
make OPT="-O3 -march=i486 -mcpu=i686" install DESTDIR=$PKG
# Install docs:
mkdir -p $PKG/usr/doc/python-$VERSION
cp -a README $PKG/usr/doc/python-$VERSION
cp -a Misc $PKG/usr/doc/python-$VERSION
( cd $PKG/usr/doc/python-$VERSION ; mkdir html )
( cd $PKG/usr/doc/python-$VERSION/html
  tar xjvf $CWD/html-$VERSION.tar.bz2
  chown -R root.root .
)
( cd $PKG/usr/bin
  rm -f python
  ln -sf python2.3 python
  chown -R root.bin .
)
( cd $PKG
  find . | xargs file | grep "ELF 32-bit LSB executable" | grep 80386 | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
  find . | xargs file | grep "ELF 32-bit LSB shared object" | grep 80386 | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
)
gzip -9 $PKG/usr/man/man1/*.?
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
makepkg -l y -c n /tmp/python-$VERSION-$ARCH-$BUILD.tgz